:[HttpWebRequest_WebException_RemoteServer] Arguments: NotFound Debugging resource strings are unavailable. Often the key and arguments provide sufficient information to diagnose the problem.

Jul 26, 2011 at 1:59 PM

Hi,

in my Visual Studio the Code and upload works fine. But if i depoly the Code to my IIS 7.5 Server it throws me this : :[HttpWebRequest_WebException_RemoteServer] Arguments: NotFound Debugging resource strings are unavailable. Often the key and arguments provide sufficient information to diagnose the problem.

 

Do you know this Problem or might got an solution for that ?

Bye

Coordinator
Jul 27, 2011 at 2:12 AM

Sorry I cant think of anything aside from the server being obstinate and not handling the connections fast enough.  You might compile a debug version and set your config to allow for debug messages to show and then alternatively run Microsoft Fiddler on your client so you can watch the activity and what URL the code is hitting to ensure that it's going to the right place.  Fiddler will also show any errors that your webserver might be throwing.   

One last thought would be to check your IIS log file while attempting to run the code and see what gets logged.

In the event that none of that pans out would be to check the Windows Log files to see if there are any indications of System or Service error.

Might just wind up being a configuration issue.

Hope this helps.

Jul 27, 2011 at 8:22 AM

Ok very nice , Fiddler did the Trick. The Path for Storefile.ashx were not relative and the application cant find it, but now i get a new error:

Btw: Thank for the Fiddler tip! Its a great tool for debug :)

Parser Error

Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

Parser Error Message: Could not create type 'LargeFileUpload.Web.StoreFile'.

Source Error:

Line 1:  <%@ WebHandler Language="C#" CodeBehind="StoreFile.ashx.cs" class="LargeFileUpload.Web.StoreFile" %>


Source File: /sfu/lf/StoreFile.ashx    Line: 1

Jul 27, 2011 at 11:15 AM

I get it to work, but only if i copied the Source-code of  StoreFile.ashx.cs in StoreFile.ashx.  If the Code is compiled into the DLL, it doesn't work. But i dont know why... Something must be wrong with the compile... ? But here i haven't much experience in such things. Sry if my english is bad ;)

Coordinator
Jul 27, 2011 at 8:33 PM

No problem and glad to hear its working for you. HTML 5 will eventually make it such that the Silverlight Client side code is not needed (once the HTML 5 File API is working across the board.)

Deploying the .cs file is not too bad but I think that in the project you might be able to set the .ashx file properties to Contents and the associated .cs file to Compile.  Or double check that the folder is set to run ASP.Net 2.0 or better.  From a Google Search I came across some similar reported problems and this link http://social.msdn.microsoft.com/forums/en-US/asmxandxml/thread/838706ac-6763-455b-95bd-1432a9ccc6be/

Not sure it will help but glad to hear you have it working.

Cheers.